[Debian] Site error: the file FILE requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator

Hinweis: Wir haben in diesem Artikel möglicherweise Provisions-Links verwendet und sie durch (*) gekennzeichnet. Erfolgt über diese Links eine Bestellung, erhält maffert.net eine Provision. Es entstehen für Sie keine Nachteile beim Kauf oder Preis.

Fehlerbeschreibung:

Beim ausführen eines PHP-Scriptes (in dem Fall ein Cronjob) das ionCube PHP Loader benötigt kommt in der Konsole folgendes:

Site error: the file <b>/var/www/bla.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.ph:~#

Fehler beheben:

In dem Tut zuvor hatte ich nur für den Webserver ioncube konfiguriert, sprich die php.ini für cgi (/etc/php5/cgi/php.ini) angepasst.

Was fehlte war aber auch die andere php.ini anzupassen, die für cli (/etc/php5/cli/php.ini)

Also einfach in der CLI php.ini (/etc/php5/cli/php.ini) noch einmal den Eintrag „zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so“ unter „engine = On“ einfügen.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.